Stick KE1 Firmware Issue

Sunlite Touch Sensitive Intelligent Control Keypad

Moderators: simonB, nick, florent, dylan, Ben

Post Reply
Posts: 1
Joined: Sun Mar 10, 2019 3:42 pm

Stick KE1 Firmware Issue

Post by jomrtns » Sun Mar 10, 2019 4:25 pm


I am in big trouble with my Stick KE1.

The Stick KE1 was working fine (standalone and using Lightpad app) until last week, but due to recent changes in light setups in company, i needed to change some setups on this stick KE1 (change of IP address, and change of some scenes). And while the Stick KE1 was ok with LightPad control, no other app were able to communicate correctly with the Stick (Arcolis on iPad was seeing the interface but unable to download or upload file, ESA2 Mac or PC couldn't see the interface at all, ESA Pro could see the interface at start in Ethernet mode only but after start was giving me Firmware version error).

So i decided to perform a firmware upgrade of the unit as it was still using an old one (V1.19 by memory).

- First problem : The Unit was abolutely impossible to reach via USB at this moment. Tried with Hardware Manager, ESA2, ESA Pro, each both PC and Mac versions. Drivers were installed correctly because the interface was showing as expected in Device Manager (Windows 10) and System Report (macOS). But no communication with any app. The unit was reachable with Ethernet in Hardware Manager, but no possibility to upgrade firmware or change IP address in this mode.

-Then i saw in KE2 document that there was a method to force firmware upgrade by using Bootloader mode. And while there is no Bootloader switch in KE1, there is a contact on board that have the same function. So after starting on Bootloader Mode, i was able to actually see the interface in Hardware Manager. I went thru the firmware upgrade process to v1.21 which seemed to go fine with success message.

But after restart, things got worse :
-The interface now shows up in Hardware Manager but with XHL-NAP error each time. Firmware version is marked as "Unknown". I tried to apply firmware again a few more times (via Bootloader mode) with same results. I then noticed in different Hardware Manager apps (the standalone ones and the one delivered in ESA2/ESA Pro installation packages) that they were all using v1.21 firmware but with different compilation dates (2017 or 2018). No change here.
-The interface when in standalone (not connected to app like ESA2) is completely unstable with DMX having a lot of errors and disconnects, leading to lights randomly starting and stopping...
-The interface is still not seen in any app in USB mode (but still appears in Device Manager as Stick KE1B) except Hardware Manager with XHL-NAP error. In was only able to reach it with ESA2 on Mac via Ethernet. Windows versions of ESA2 and ESA Pro are crashing at launch after selecting the interface in Ethernet...
-When i'm connected with ESA2 Mac via Ethernet the interface is actually more stable. I am able to control DMX levels from app. And i am able to erase and write memory from ESA 2 ONLY if the interface has been flashed with the firmware v1.21 compiled in 2017. v1.21 compiled in 2018 gives me error when i try to write from ESA 2. And in both case i get error if i try to read from memory.
-Arcolis still sees the interface but gives error when trying to connect.
-LightPad still works
-I tried to format and change the microSD card any change appart from losing my scenes..

So right now i have an interface which is completely unstable when in standalone (which is my use of the interface), impossible to firmware update appart from starting in Bootloader mode each time (because of XHL-NAP error in Hardware Manager). I can only write scenes from ESA2 on Mac if i use the firmware V1.21 compiled in 2017 (the one that is unluded in the ESA2 Hardware Manager package). And they are not really usable anyway...

Is there an other way to perform the firmware upgrade (via SD Card?)? What is the XHL-NAP error? Is it possible to find older firmware than v1.21 to see if can put this unit back to stable usage as it was in v1.19? Any idea of this unstable behavior?

Thanks for any help! And sorry for the long story...

Maxi Forumor
Posts: 282
Joined: Fri Feb 12, 2016 2:37 pm

Re: Stick KE1 Firmware Issue

Post by nick » Mon Mar 11, 2019 12:21 pm


I am sorry you have experienced these problems.

The XHL-Nap problem, since updating to 1.21, is most likely the cause of the problems you describe. This problem happens with a small number of interfaces and can be solved by starting a support ticket here.

Please copy and paste the forum post into the support ticket.

Kind Regards,

Nicolaudie Tech Support

Post Reply