DasHard2006.dll block device for Easy View 3D

Easy view 2006, the ideal “3D real time” simulation to visualize stage and lights simultaneously !

Moderators: simonB, nick, florent, RichterMC, dylan, Ben

Post Reply
Andy
Posts: 1
Joined: Mon Oct 03, 2011 5:53 pm

DasHard2006.dll block device for Easy View 3D

Post by Andy » Mon Oct 03, 2011 6:21 pm

Hi Guys,

I have last days searched for a problem with Easy View 3D. I'm everytime thinking I have made the problem by my self.
What have I make? I develope since 2007 a own program for my private partys (Thanks Bruno and Marc!).
The program runs fine, but only on Windows Vista 32 Bit. I have reinstalled my workstation 2009 with Win7 x64 and have first last weeks found the problem (I make not every days party :-)
I use SIUD6C, i have one with firmware 113 and one with 115. Both devices runs fine without problems.

I have search, and search and tested and copy to other workstation with Vista 32 Bit. I think I have found the problem.
On Vista 32 Bit: Starting my program, my program talks with DasHard2006.dll, the Lights in my Partyroom runs. I start with my program "Easy View 3D" (with MEVP.dll - thanks Bruno and Marc) and Easy View 3D runs fine.
On Win7 64 Bit: Starting my program, my program talks with DasHard2006.dll, the lights in my Partyroom runs. I start with my program "Easy View 3D" (with MEVP.dll) and Easy View 3D says in a Message-Box "No interface or password wrong".
If I start Easy View 3D over "Start -> Programs" Easy View 3D says "No USB-DMX device found" or "No USB-DMX device connected". But if I stop my own program (and the USB-DMX is free) Easy View 3D starts without problem. But this is only on Win7 x64, not with Vista 32-Bit.

On Win7 x64 I can use SunLite Suite 2 with Easy View 3D without problems, but SLSUITE2 use not DasHard2006.dll.
I think is only a problem with DasHard2006.dll, this libary "blocking" the USB-DMX Device under x64, and Easy View 3D think is no more device connected. Is only an idea from me, but it is a problem for me and my own program. Please Bruno, Marc, do not tell me that i must reinstall my OS to x86.
I think the MEVP.DLL is not the problem, then, i can no start "Easy View 3D" over Start->Prorgrams. I think this is DasHard2006.dll or the Driver for x64.
Hope you can help me.

Best regards
Andy

Post Reply