Problem with micro pan/tilt when limiting the area

New features and a new user interface.

Moderators: simonB, nick, florent, RichterMC, Ben

Post Reply
mikachu
Junior Forumor
Posts: 23
Joined: Wed Apr 16, 2003 2:33 pm
Location: Saint etienne France

Problem with micro pan/tilt when limiting the area

Post by mikachu » Wed Dec 06, 2017 11:28 am

*** already posted on the SL2 forum but without any feedback. This bug is also present in SL3
Hi,

I've got a strange behaviour when limiting Pan/tilt on a Micro Pan/tilt enabled fixture.

I've seen that when slowing down a movement to have a really slow panning, the pan and micropan aren't synced at all making the fixture "wooble".

On a non limited area pan and micro pan are synced and when micro pan comes up to 255, pan increases of 1 and micro pan falls to 0 making a really smooth effect

When limiting the area, they are not synced anymore. When the micro pan comes up to 255, pan doesn't increase of 1 but micro fan falls to 0 making the fixture go backward, slightly later pan increases of 1 making the fixture go forward really hardly.

DATechnics
New Forumor
Posts: 5
Joined: Wed Dec 16, 2015 12:30 pm

Re: Problem with micro pan/tilt when limiting the area

Post by DATechnics » Thu Dec 07, 2017 5:36 pm

Hi mikachu,

same problem. Not only, when limiting Pan/Tilt, but always when you slow down a movement.
I've made a topic here: http://forum.nicolaudie.com/viewtopic.php?f=45&t=41032
and also for SL2: http://forum.nicolaudie.com/viewtopic.php?f=32&t=39369

I really hope, this issue will be analyzed by Nicolaudie Team.

Best regards
Alex

nick
Maxi Forumor
Posts: 282
Joined: Fri Feb 12, 2016 2:37 pm

Re: Problem with micro pan/tilt when limiting the area

Post by nick » Thu Dec 21, 2017 5:20 pm

Hi,

Thank you for these reports. I started testing today with the generic moving head (16bit movement), with restricted movement and visually noticed some 'wobble' in the 3D viewer. Are you experiencing this in the real world, with moving heads? I will look into it in more detail with further tests after the Christmas break.

Kind Regards,

Nick.
Nicolaudie Tech Support

mikachu
Junior Forumor
Posts: 23
Joined: Wed Apr 16, 2003 2:33 pm
Location: Saint etienne France

Re: Problem with micro pan/tilt when limiting the area

Post by mikachu » Tue Dec 26, 2017 8:48 pm

yes, it happens in the real world and that is where I noticed it. You only have to look at the DMX out window to understand it. to my mind, the restriction area is based on some kind of offset. This offset got to be mapped to the Pan/tilt channels but not to the micro pan/tilt.

mikachu
Junior Forumor
Posts: 23
Joined: Wed Apr 16, 2003 2:33 pm
Location: Saint etienne France

Re: Problem with micro pan/tilt when limiting the area

Post by mikachu » Tue Dec 26, 2017 10:01 pm

I just found something that could help you find the bug.

If you reduce the area by 50% in height and width, the "shrinked" data outing from the dmx out should be 127.255/127.255 while it outs 255.255/255.255 from the fixture window. When the micro pan or tilt raises of 2 from the fixture window, it should raise of 1 on the DMX output.

If you limit the area during the page creation process, the micro pan/tilt are not submitted to the offset. For example if you drasticly reduce the area by 10, the micro pan tilt goes from 0 to 255 10 times before the pan raises of 1. That leads to this whoobeling effect.

But if you reduce the area after the page creation (or simply modify it) through menu page/ settings / patch / XY everything seems to run well and the ratio is mapped to XY and Micro XY.

That happens also in SL2

only tested that offline, got now to confirm in the real world

nick
Maxi Forumor
Posts: 282
Joined: Fri Feb 12, 2016 2:37 pm

Re: Problem with micro pan/tilt when limiting the area

Post by nick » Thu Jan 11, 2018 5:01 pm

Hi mikachu and Alex,

I hope you had a good Christmas.

I have now replicated this problem both in Sunlite Suite 2 and 3 and have reported it on our bug reporting system to fix. The problem occurred when the X/Y grid is restricted only and it happens in both the 3D viewer and in reality when connected to a moving heading with 16bit movement channels.

There is a temporary solution before we release the fix ...
- Create your movement effect first. Play it and notice it wobbles.
- Go to page settings
- Patch window
- Cog icon (settings / top right). You will see the movement grid but don't change anything.
- Click Ok. Now play back the movement and it will be smooth! I don't know why but it works as a temporary fix.

Kind Regards,

Nick.
Nicolaudie Tech Support

Post Reply