Crash when Button has Multimedia with special char in name

Sunlite Suite 2 is a complete re-design of Suite 1. Please discus any issues here

Moderators: simonB, nick, florent, RichterMC, dylan, Ben

Post Reply
hsteppke
Super Forumor
Posts: 101
Joined: Tue Jan 25, 2011 7:57 am

Crash when Button has Multimedia with special char in name

Post by hsteppke » Tue Oct 21, 2014 10:38 pm

Hi, Hi,

Sunlite Suite crashes if there is eg an ' in the filename of a Button in the XML it is escaped using ' however if i load Sunlite it where crashing.
I could nail id down to the Button below in the _MASTER file if i within the file change the Name of the file to something that doesn´t have the ' it stops crashing.
Tested in 23.Sept.2014 (BTW havn`t seen a changelog yet but its on the Page to be downloaded) also in the 13.Aug.2014 and also in the 3.10.2014 Beta.
I tryed to replace it with an ' .. same issue...

For me it would be enough if it would not crash, maybe can´t read the file but-

Holger


Code: Select all

<scene Author="dylan" Version="1.0" Dimmer="65535" Speed="0" PhasingCourbe="0" Phasing="0" Size="0" TypeButton="1" Shortcut="0" ShortcutFugitif="0" Port="-1" PortFugitif="0" DontReleaseOther="1" ReleaseOther="0" FlagSlider="0" FlagWorkSlider="0">
  <Multimedia File="M:\MUSIK\EINSORTIERT\BYGENRE\SOUNDTRACK\15 HE&apos;S A PIRATE.MP3" SX="0" SY="0" Loop="1" TimeStart="0" TimeEnd="-1" StopWhenOtherStart="0" />
  <EasyShow State="0" Command="0" BreakPoint="" File="" />
  <Editor EasyTimeZoom="8" EasyTimeShowIcon="0" EasyTimeCompressColorXY="1" EasyTimeShowSelected="0" EasyTimeCompress="0" EasyTimeMagnetism="1" EasyTimeMagnetismValue="1" FixturesShowBeam="1" EasyTimeModeTempo="0" EasyTimeModeTempoFade="1" EasyTimeModeTempoPulse="0" EasyTimeMesures="4" EasyTimeMesureTimer="25" />
  <Switch WorkingType="0" AutoRelease="1" ReleaseOnDblClick="1" DoLimitedTime="0" LimitedTime="801" AllwaysOn="0" DoFade="0" FadePlaySeq="0" FadeTime="100" />
  <Scene DoFade="0" FadeSpeedReset="1" FadePlaySeq="0" FadeTimeBeforeUp="0" FadeTimeUp="500" FadeTimeBeforeDown="0" FadeTimeDown="500" DoFadePause="0" />
  <EasyStep Loop="1" ModeAvanceLecture="0" AvanceLectureFade="1" NbStep="1">
    <Time Fade="0" Wait="25" />
  </EasyStep>
  <Fxs />
  <Fxs>

    <Fx ID="9" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="10" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="11" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="12" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="13" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="14" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="6" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="7" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="8" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="15" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />




    <Fx ID="1" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="2" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="4" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="5" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="3" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="21" LibName="AMERICAN DJ\H20 LED DMX PRO.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="26" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="27" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="28" LibName="_OWN\3AXISSKULL.SSL2" Activated0="1" Activated1="1" InvPan0="0" InvTilt0="0" InvPan1="0" InvTilt1="0" />
    <Fx ID="29" LibName="_GENERIC\RGB.SSL2" Activated0="1" Activated1="1" InvPan0="0" InvTilt0="0" InvPan1="0" InvTilt1="0" />
    <Fx ID="31" LibName="LOOK SOLUTIONS\UNIQUE.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="36" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="37" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="38" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="30" LibName="INVOLIGHT\LED BAR 390.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="32" LibName="INVOLIGHT\LED BAR 390.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="33" LibName="INVOLIGHT\LED BAR 390.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="34" LibName="INVOLIGHT\LED BAR 390.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="35" LibName="INVOLIGHT\LED BAR 390.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="39" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="40" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />
    <Fx ID="41" LibName="_GENERIC\SINGLE CHANNEL.SSL2" Activated0="1" InvPan0="0" InvTilt0="0" />

  </Fxs>
  <DmxInRecorder />
</scene>


simonB
SuperMaxi Forumor
Posts: 1630
Joined: Thu Sep 17, 2009 1:50 pm

Re: Crash when Button has Multimedia with special char in na

Post by simonB » Thu Oct 30, 2014 9:43 am

Hi Holger

Unfortunately I'm not able to re-produce this bug, I've checked the button file and have written the same name but with no problem. Could you try creating a brand new show with 1 button triggering a different multimedia file with ' in the title to see if you still get the crash?
Simon
--
Sales/Support

Post Reply