SLEA-UE7 DMX traffic just stops after 24 hours idle

SLESA-U7 - SLESA-UE7 - SUITE2-FC

Moderators: simonB, nick, florent, dylan, Ben

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Tue Jul 28, 2015 12:21 am

We are currently having an issue with our SLEA-UE7 unit. Right now I have the unit running 24 hours/day in stand alone mode. It is running the Feb 12,2015 release. The problem is that after 2 or 3 days the DMX traffic to the lights just stops. This has been going on for quite some time but I didn’t report it due to trying different grounding configurations to see if it would go away. The unit will still respond by pressing the up/down buttons on the unit and the display will show A01, A02, A03. . . messages but the DMX lights never change. I connected a scope to the DMX output and it is completely idle. No data or Break conditions seen at all. The DMX cable from the SLEA-UE7 goes directly into a http://www.chauvetlighting.com/data-stream-4.html optical splitter that has a 120 ohm terminator on the Thru connection. I wonder if this could be a software problem such as missing an interrupt or something like that. If I cycle the power to the SLEU-UE7 then everything starts working again. I haven’t noticed any difference between the lights on the unit when it is working or not working. Have you seen anything like this? Please help.

Pete

Ben
Super Forumor
Posts: 153
Joined: Wed Mar 25, 2015 2:55 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by Ben » Tue Jul 28, 2015 10:29 am

Hi Pete,

Can I first check that the device is updated to the latest firmware (Direct link to latest Hardware Manager below)?
http://www.dmxsoft.com/global/ftp/HardwareManager.exe

Also if you are using ESA Pro please could you try with the latest Beta version which I have included a link to below.
http://www.nicolaudie.com/downloads/fil ... robeta.exe

Let us know if you're still having problems and I can look into it for you further.
Benno
--
Product Support

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Tue Jul 28, 2015 3:04 pm

Will update the hardware in the near future when I go into work with my PC. You won't hear from me for a few days depending on what I find. I have been using the ESA2 software only. At this time I have the hardware installed but only 1 test fixture running in the back room.

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Tue Jul 28, 2015 11:10 pm

This morning I went in and low and behold, the DMX output was not working. Before I did anything and with the router already connected, I just executed the HARDWARE.EXE command and it connected without any issue. At this point the SLEA-UE7 controller was talking to the fixture and sending out DMX data. I went to the page where I can set values to the DMX fixture and it worked fine. So just connecting thru the wireless router caused the DMX interface to start working again.

At this point I thought I would just download the controller with new firmware but I found out that this only works with the USB connection. I ran into other issues. I had loaded the link you gave me into a new directory and when I tried to execute the software, the USB port was not found and would not connect. After a few tries of deleting and installing the SUDI drivers, I finally copied all of the files found in your new link into my ESA2 directory and reinstalled the drivers. I can now connect using the USB connection.

The next issue was when I went to update the firmware, both the loaded and new version of software showed a date of “2015-01-23”. I went ahead and did the update anyway but I don’t know if it got the update that you wanted me to use? The version shows 1.22 but isn’t this the old version?

Pete

Ben
Super Forumor
Posts: 153
Joined: Wed Mar 25, 2015 2:55 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by Ben » Wed Jul 29, 2015 9:38 am

Hi Pete,
At this point I thought I would just download the controller with new firmware but I found out that this only works with the USB connection.
The firmware can only be updated over USB not ethernet
The next issue was when I went to update the firmware, both the loaded and new version of software showed a date of “2015-01-23”. I went ahead and did the update anyway but I don’t know if it got the update that you wanted me to use? The version shows 1.22 but isn’t this the old version?
1.22 2015-01-23 is the latest firmware version for your device.
I finally copied all of the files found in your new link into my ESA2 directory and reinstalled the drivers.
Please download and install the latest version of Easy Stand Alone 2 - Date 01 Jul 2015
http://www.nicolaudie.com/downloads/files/ESA2.exe

Try with the latest version of ESA2 and let us know if you'll still having problems.
Benno
--
Product Support

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Wed Jul 29, 2015 2:30 pm

I went and installed the link you provided. I was surprised at how long it took to do the “SSL Library” part of the install. I waited for about 8 minutes then decided to take a shower. When I came out it was done, thank goodness.

When I go into work I will reinstall the firmware and then reboot the hardware. Is it OK to read the old original configuration from the SIUDI or should I start from a clean config and regenerate the scenes from scratch and rewrite them?

Pete

PS- Something I should also tell you is that I don’t really know when it stops sending the DMX data. During working hours the scenes are being changed thru the HE-10 port. Maybe 1-3 scene changes per minute average over a 5 hour period. I don’t really know if the lockup occurs in the middle of the busy time or over night when it is idle. Sorry for not telling you about this earlier.

Being a design engineer myself I know how difficult these intermittent issues are to solve some times.

Ben
Super Forumor
Posts: 153
Joined: Wed Mar 25, 2015 2:55 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by Ben » Thu Jul 30, 2015 9:40 am

Hi Pete,
When I go into work I will reinstall the firmware and then reboot the hardware. Is it OK to read the old original configuration from the SIUDI or should I start from a clean config and regenerate the scenes from scratch and rewrite them?
Not necessary to restart from scratch at this point but you could create a simple new test show to see if you're having the same problems with that. I would recommend removing the SD card and formatting in your computer then re-writing the show to the device.
PS- Something I should also tell you is that I don’t really know when it stops sending the DMX data. During working hours the scenes are being changed thru the HE-10 port. Maybe 1-3 scene changes per minute average over a 5 hour period. I don’t really know if the lockup occurs in the middle of the busy time or over night when it is idle. Sorry for not telling you about this earlier.
The more info you can give us as to when the problem occurs the better, so we can determine where the problem might be. How often does it happen, is it happening everyday?

Also if you email us over your showfile I can take a look at it.
Benno
--
Product Support

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Mon Aug 03, 2015 3:33 am

I went into Organ Stop Pizza this Sunday night and sure enough, the DMX traffic had stopped. At this point I disconnected the HE-10 dry contact interface that changes the scenes and power cycled the SLEA-UE7. I will now wait for a few days and see if it still fails. For some reason my intuition thinks it will work fine.

About 2 weeks ago I added a 2,200 uf capacitor to the 5v line thinking it could be a power issue. The MidiBox PIC CPU that controls the scene changes to the HE-10 interface has never had a hick-up and has been running fine even without the new capacitor.
BTW - I isolated the dry contacts of the HE-10 connector with 8 diodes that point away from the SLEA-UE7 box. The PIC CPU is controlling the port by outputting the data to the TRIS port which controls the tri-state value of the parallel 8 bit port. So it should control the port by sinking or tri-stating the signals on the HE-10 port. I added the diodes in case the PIC software failed and tried to pull the HE-10 ports to +5v which would be bad.

Ben
Super Forumor
Posts: 153
Joined: Wed Mar 25, 2015 2:55 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by Ben » Tue Aug 04, 2015 10:51 am

Hi Pete,

Thanks for the info, I have replied to your email and will runs some test here in the office with your showfile.

Kind regards
Benno
--
Product Support

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Fri Aug 07, 2015 3:18 am

Well its been 4 days and the SLEA-UE7 is outputting DMX data just fine. It was running a scene that faded back and forth between 2 patterns. It must be problems in outputting the scene changes using the HE-10 interface since this was disconnected 4 days ago.

My next step is to change my PIC controller software a bit. Right now if there is a rapid scene change then there could be a case that the 2nd HE-10 signal change will be outputted without waiting for the previous signals from being cleared. I will wait about 250ms before the next change will be sent. Will try to implement this change tomorrow then wait and see if my problem goes away.

The organists have asked to be able to select what I am calling a sub-scene in a sequence of scenes using a NEXT and PREVIOUS button. What this does is take the current scene value and increment it and outputs the new scene+1 value. So if we are on scene 30 and the next button is pressed, then scene 31 will be outputted to the HE-10 port. If the scene isn't defined in the show file, then it is expected to do nothing. I am seeing this scene+1 function being executed some of the time which then sends an undefined trigger out the HE-10 port. This could be part of the problem but for now I will just make sure that the 2 scene changes are not being merged together with this next change on my side.
I hope this makes sense.
Pete

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Fri Aug 07, 2015 11:01 pm

Well its the end of the day on Aug 7 and I made the change to my PIC controller. When a trigger value is output to the HE-10 port it will stay there for 250ms and won't be changed. Then the HE-10 signals will be all set high for another 250 ms which will be like releasing the buttons. After this cycle has completed then a new trigger value can be sent.

Now the waiting continues to see if this fixes my problem.

Pete

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Tue Aug 11, 2015 2:01 pm

Not good news. On Sunday night (Aug 9) I went in and all was working fine. But when I went in Monday morning the DMX had stopped. I will have to verify that my software is doing what I intended at the HE-10 port using the USB connection and monitoring the HE-10 bits using the HARDWARE.EXE software. Will do this in the next few days when I have time to go into work.

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Wed Aug 12, 2015 11:03 pm

Wouldn't you know it that my change wasn't doing what it was supposed to do. It never released the last switch trigger value. Reprogrammed it again and tested if the release was being done right. Its good now. Will wait again for a few days.

While going thru the code I noticed something else I should tell you. Because of the lack of a free 8 bit port, I had to do the outputting over 2 ports. I made the delay as small as possible. The code that does this is shown below.
movwf TRISA; Output current Scene to port.
movf TMP1,w; *
movwf TRISE; *
So the delay between the changes on the pins could be 200ns total.

Pete

peteknobloch
Junior Forumor
Posts: 41
Joined: Sat Mar 07, 2015 10:06 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by peteknobloch » Fri Aug 14, 2015 8:51 pm

Well even with my changes in my software, it failed after 1 day. I am at a loss as to where to go from here.

Ben - Have you been able to test changing a lot of scene changes from the HE-10 port at your location. I don't think this issue would be a problem with the SLEA-UE7 hardware since all the lights, display and network connections are working fine when this problem is seen. Do you think changing to another SLEA-EU7 unit might be the next step?

Another direction might be for your software people to add a temporary change into the product that would monitor that the DMX software is outputting the DMX data, and if it stops for some reason (maybe 2 seconds), that it could somehow restart the DMX state machine.

I really don't know where to go from here without your help.

Something else I was wondering about how your system works, does it read the SD-card for every scene change? If there was a problem reading the SD-card, would the DMX output stop due to this type of error?

Pete

Ben
Super Forumor
Posts: 153
Joined: Wed Mar 25, 2015 2:55 pm

Re: SLEA-UE7 DMX traffic just stops after 24 hours idle

Post by Ben » Mon Aug 17, 2015 12:58 pm

Hi Pete,

Just to confirm I did run tests on your show using the UE7 here in the office and unfortunately couldn't replicate your problem. We tested the show without using the HE-10 port, manually changing the scenes and leaving the show running for a few days and overnight connected to a DMX tester but it worked okay without freezing. I have also tested it using the HE-10 port, making multiple change, but still the device worked okay and experienced no DMX output problems.

Just to rewind a few steps so I understand things correctly, you say that when you stopped using the HE-10 port and ran some tests, your device worked okay with no DMX output problems? Just want to be 100% sure the HE-10 is causing the problem before we move onto investigating more things.

Kind regards,
Benno
--
Product Support

Post Reply