Sunlite Suite Midi control

Sunlite Suite, the lighting control software which even outshines most of the consoles available on the market !

Moderators: simonB, florent, RichterMC, dylan

Post Reply
nathanf
Posts: 1
Joined: Tue Feb 09, 2010 6:40 pm

Sunlite Suite Midi control

Post by nathanf » Tue Feb 09, 2010 6:54 pm

OK I'm new to Sunlite Suite and very new to midi control, but so far I have got my midi controller hooked up and working fine. Here's the problem, I'm not using the normal Behringer BCF controller, instead I've connected up my Behringer LC2412 which rather than just being a midi controller it's a midi compatible lighting desk. Now the faders work fine, I've got all 24 cotrolling Sulite Suite and all the buttons work too BUT ONLY as flash buttons, I want them to lock on. Not knowing anything about midi I'm not sure if this can be done. Using the midi test feature in SS I can see the button is sending the velocity value 127 when pressed and 0 when released. I'm guessing I would need to change a setting on the desk rather than SS but not sure this can be done.

Any help really appreciated.

Tks for reading!

simonB
SuperMaxi Forumor
Posts: 1630
Joined: Thu Sep 17, 2009 1:50 pm

Re: Sunlite Suite Midi control

Post by simonB » Wed Feb 10, 2010 12:46 pm

Hi

All MIDI commands from the lighting desk will be mapped to a button on the MIDI console in Sunlite Suite.
1.map a button on your desk to activate a button in Sunlite Suite (as usual)
2.Open up the console panel
3.Find the corresponding button and right click it
4.You should see your command listed, have a play around with the "Type of action" values. Without knowing exactly what information is being sent from your controller I don't know what to set these values at.

If you still can't get it to work, it could be an issue with the console design (I'm guessing you are useing one of the preset consoles and havn't designed your own)...
1.Close Sunlite Suite
2.Navigate to the Sunlite directory and open up EasyConsole.exe
3.open up the console you have been using in the editor
4.Select the button your have been using and change the property "Mode Poussoir" to False (the last value in the properties panel on the right)
5.reopen Sunlite Suite and try the button

Hopefully one of these should solve your problem
Simon
--
Sales/Support

Post Reply